Best Genshin Impact Tier List

Incident Report for Genshin Impact

Update

We are continuing to investigate this issue.
Posted Oct 25, 2022 - 00:54 UTC

Investigating

a
Posted Oct 22, 2022 - 12:13 UTC